NJU1healer的个人博客分享 http://blog.sciencenet.cn/u/NJU1healer

博文

.whl is not a supported wheel on this platform的原因及其解决办法

已有 2933 次阅读 2020-5-26 22:36 |个人分类:Coding bug|系统分类:科研笔记

在PIP安装.whl文件的时候碰到这个错误,具体如下:


我的python版本是3.4.4,这个错误的原因如下

可能的原因1:安装的不是对应python版本的库,下载的库名中cp27代表python2.7,其它同理。
可能的原因2:下载的是对应版本的库,然后仍然提示不支持当前平台,文件名格式不对


1.首先第一个错误:

我下载的是CP37,pyth版本是3.4.4,所以下载文件错误,重新下载带CP34的(opencv_python-3.1.0-cp34-cp34m-win_amd64.whl),

还是报错,opencv_python-3.1.0-cp34-cp34m-win_amd64.whl is not a supported wheel on this pl
atform.

2.第二个错误就是文件名有误

在shell中输入import pip; print(pip.pep425tags.get_supported())可以获取到pip支持的文件名还有版本


通过这里可以发现上面下载的文件名格式是不支持的,修改为:opencv_python-3.1.0-cp34-none-win_amd64.whl,安装成功


(python库下载地址(库很丰富,下载速度也很快):http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy)

参考连接:

http://www.cnblogs.com/nice-forever/p/5371906.html




https://wap.sciencenet.cn/blog-3428464-1235100.html

上一篇:RuntimeWarning: invalid value encountered in true_divide
下一篇:在python中安装包出现Retrying (Retry(total=4, connect=None, read=Non

0

该博文允许注册用户评论 请点击登录 评论 (0 个评论)

数据加载中...
扫一扫,分享此博文

Archiver|手机版|科学网 ( 京ICP备07017567号-12 )

GMT+8, 2022-5-21 19:35

Powered by ScienceNet.cn

Copyright © 2007- 中国科学报社

返回顶部