xiaoairen322的个人博客分享 http://blog.sciencenet.cn/u/xiaoairen322

博文

关于geopandas 与 contextily 安装冲突的解决方法

已有 576 次阅读 2021-3-4 16:03 |个人分类:python 语言学习|系统分类:科研笔记

geopandas  contextily


geopandas 的安装依赖fiona,fiona依赖gdal 库,所以在安装geopandas 库时,会将gdal库安装。

但是在安装contextily 库配合geopandas库进行绘图操作时,contextily又依赖rasterio库,rasterio的安装必须是在gdal 的安装完成下进行的 ,二者对gdal 库的版本要求不一样,所以经常导致冲突,二者不能共用,在giseden社区及费弗里大神的指导下,通过虚拟环境,版本隔离将其安装成功 ,在此分享一下经验,在此提醒大家,在进行包测试时通常使用虚拟环境,以免破坏大的安装环境。



通过source 改变底图

gallery_plotting_basemap_background_8_0.png

gallery_plotting_basemap_background_10_0.png




https://wap.sciencenet.cn/blog-3387053-1274999.html

上一篇:jupyter notebook 遇到的问题 " DLL load failed"
下一篇:关于G-NUT/Anubis 绘图的一些补充

0

该博文允许注册用户评论 请点击登录 评论 (0 个评论)

数据加载中...
扫一扫,分享此博文

Archiver|手机版|科学网 ( 京ICP备07017567号-12 )

GMT+8, 2021-5-11 22:19

Powered by ScienceNet.cn

Copyright © 2007- 中国科学报社

返回顶部